random problem.

Charging, starting, lighting, gauges, HVAC

Moderators: FORDification, Thunderfoot

Rustybones
New Member
New Member
Posts: 9
Joined: Thu Apr 28, 2016 9:45 am

random problem.

Postby Rustybones » Wed Feb 07, 2018 9:46 am

I went to start my truck this morning, it cranked, and died mid crank after a little pop.Lights went out, and nothing will work. Any one got any ideas? My electrical knowledge is sadly lacking.

User avatar
1972hiboy
100% FORDified!
100% FORDified!
Posts: 2186
Joined: Thu Sep 09, 2010 5:44 pm
Location: California, Santa Cruz
Contact:

Re: random problem.

Postby 1972hiboy » Wed Feb 07, 2018 11:21 am

I'd try tightening the battery terminal connections first.
Rich
1973 f350 super c/s 460/c6 22k orig miles
1972 f350 srw crewcab special 390
1972 f250 ranger XLT Camper Special 390
1972 f250 4x4 custom 84k og miles 390
1971 f250 4x4 sport custom 56k og miles. 360
1970 f250 4x4 428 fe hp60 205 d60
Dont eat yellow snow.....

Ohiotinkerer
Preferred User
Preferred User
Posts: 402
Joined: Wed Nov 09, 2016 5:49 pm
Location: Galion, Ohio

Re: random problem.

Postby Ohiotinkerer » Wed Feb 07, 2018 2:38 pm

:yt:

Clean and retighten - mine did the same thing and that's what it was......and its the easiest place to start....... :D
"Life is a garden - dig it"........... :thup:

1968 F100 Baseline 2wd - Rangoon Red - 360 2bbl - T18 - power steering and manual brakes
1997 Honda CBR 900RR
1977 MonArk 14 ft jon boat with a 1963 Johnson JW-18 3hp outboard

Rustybones
New Member
New Member
Posts: 9
Joined: Thu Apr 28, 2016 9:45 am

Re: random problem.

Postby Rustybones » Sun Feb 11, 2018 9:29 am

Battery post were good, the ground wire cam unbolted.


Return to “Electrical & Wiring”

Who is online

Users browsing this forum: No registered users