I'm desperate gauge cluster help

Inside the cab...appearance, repair, upgrades

Moderator: FORDification

Doorjam13
New Member
New Member
Posts: 20
Joined: Thu Mar 16, 2017 10:36 pm

I'm desperate gauge cluster help

Postby Doorjam13 » Sat Nov 04, 2017 2:30 pm

:? I have posted something about this a while back and did the things that were recommended and still I can't get any of the cluster to work.

So for the only thing that works is the mechanical speedo and the blinker, None of the backlights or the other gages work. I have power to circuit board and light bulbs are new. I also checked the ground wires. I have cleaned all the electric contacts.

I'm at a loss I don't know what to do next.

User avatar
basketcase0302
100% FORDified!
100% FORDified!
Posts: 5814
Joined: Thu Jan 26, 2006 7:11 am
Location: Tennessee, Chattanooga (Choo-Choo town)

Re: I'm desperate gauge cluster help

Postby basketcase0302 » Sat Nov 04, 2017 9:09 pm

"Doorjam13"]:? I have posted something about this a while back and did the things that were recommended and still I can't get any of the cluster to work.
So for the only thing that works is the mechanical speedo and the blinker, None of the backlights or the other gages work. I have power to circuit board and light bulbs are new. I also checked the ground wires. I have cleaned all the electric contacts.
I'm at a loss I don't know what to do next.



Do you mean just the lights for the panel don't work? It gets it's power from the rheostat on the headlight switch which is a common failure causing loss of power to the panel.
You said you have power to the panel-exactly what voltage are you reading there and what year truck is this?
Jeff
viewtopic.php?f=22&t=46251
SOLD-71 F-350 dually flatbed, 302 / .030 over V-8 with a "baby"C-6, B & M truckshifter, Dana70/4.11 ratio, intermittent wipers, tilt steering, full LED lighting on the flat bed, and no stereo yet (this way I can hear the rattles to diagnose)! SOLD!
A lot of "oddball" Ford parts collected from working on them for 34 years now!
2008 Ford Escape 4 x 4

I'm "on the fence" about another bump right now / still looking at them / but not real sure if I'm ready for it or not (until I get moved). :(

Doorjam13
New Member
New Member
Posts: 20
Joined: Thu Mar 16, 2017 10:36 pm

Re: I'm desperate gauge cluster help

Postby Doorjam13 » Sat Nov 04, 2017 10:08 pm

I don't have a voltage meter.... as of yet. All other lights work on the truck except the cluster lights(light the back of the gauges to see at night) The blinker indicator in the cluster does works. And the guages themselves do not read anything(oil, fuel, temp and volts).

User avatar
basketcase0302
100% FORDified!
100% FORDified!
Posts: 5814
Joined: Thu Jan 26, 2006 7:11 am
Location: Tennessee, Chattanooga (Choo-Choo town)

Re: I'm desperate gauge cluster help

Postby basketcase0302 » Sun Nov 05, 2017 5:40 am

"Doorjam13"]I don't have a voltage meter.... as of yet. All other lights work on the truck except the cluster lights(light the back of the gauges to see at night) The blinker indicator in the cluster does works. And the guages themselves do not read anything(oil, fuel, temp and volts).


What year truck is this, (will help for future issues if you put a year model truck in your signature as each are different) helps us-to help you.
Earlier models of the bump trucks had hard wiring on the back of the instrument panel and the later models had a printed circuit board for the lighting and gauge wiring on the instrument panel-so we first need to know what year truck it is.
Jeff
viewtopic.php?f=22&t=46251
SOLD-71 F-350 dually flatbed, 302 / .030 over V-8 with a "baby"C-6, B & M truckshifter, Dana70/4.11 ratio, intermittent wipers, tilt steering, full LED lighting on the flat bed, and no stereo yet (this way I can hear the rattles to diagnose)! SOLD!
A lot of "oddball" Ford parts collected from working on them for 34 years now!
2008 Ford Escape 4 x 4

I'm "on the fence" about another bump right now / still looking at them / but not real sure if I'm ready for it or not (until I get moved). :(

Doorjam13
New Member
New Member
Posts: 20
Joined: Thu Mar 16, 2017 10:36 pm

Re: I'm desperate gauge cluster help

Postby Doorjam13 » Sun Nov 05, 2017 9:28 am

1972

User avatar
basketcase0302
100% FORDified!
100% FORDified!
Posts: 5814
Joined: Thu Jan 26, 2006 7:11 am
Location: Tennessee, Chattanooga (Choo-Choo town)

Re: I'm desperate gauge cluster help

Postby basketcase0302 » Sun Nov 05, 2017 2:53 pm

"Doorjam13"]1972


Your 1972 will have the printed circuit board on the back like part number 10K843 in the top image on this page, (unless someone has changed out the panel which is doubtful):
Image

Here's another good image of what your looking at. The harness plugs into the printed circuit board and powers the lamps, (part number 13711 of which there are six of them). A lot of times these bulbs are the issue and are also easily tested (also using a voltage meter-a crummy "test probe" will also be useless to test the bulbs):
Image

You really first need to get a cheap voltage meter which can be bought anywhere for less than $10.00 like this one-and easily learn to read it here on the forum, (not a crummy test lamp that destroys your wiring harness by piercing the wiring insulation) and test for "voltage" (not just "power) to the instrument panel (as once again it gets "voltage" from the headlight switch rheostat) and you need to know exactly what it is getting :
https://www.harborfreight.com/7-functio ... 90899.html

Once you've determined the voltage from the headlight switch rheostat is correct, (should be anywhere from 5 VDC to 12 VDC) then you start testing the "sockets" on your instrument panel circuit board. You need to test for voltage on wire #19 A/B in this image (which is the blue with red stripe wire in the harness that feeds the instrument panel). :thup:

Image
Jeff
viewtopic.php?f=22&t=46251
SOLD-71 F-350 dually flatbed, 302 / .030 over V-8 with a "baby"C-6, B & M truckshifter, Dana70/4.11 ratio, intermittent wipers, tilt steering, full LED lighting on the flat bed, and no stereo yet (this way I can hear the rattles to diagnose)! SOLD!
A lot of "oddball" Ford parts collected from working on them for 34 years now!
2008 Ford Escape 4 x 4

I'm "on the fence" about another bump right now / still looking at them / but not real sure if I'm ready for it or not (until I get moved). :(

Doorjam13
New Member
New Member
Posts: 20
Joined: Thu Mar 16, 2017 10:36 pm

Re: I'm desperate gauge cluster help

Postby Doorjam13 » Tue Nov 07, 2017 7:15 pm

I have zero volts at the Blue w/red wire but 11.4 ish from the other wires at the head light switch.

User avatar
basketcase0302
100% FORDified!
100% FORDified!
Posts: 5814
Joined: Thu Jan 26, 2006 7:11 am
Location: Tennessee, Chattanooga (Choo-Choo town)

Re: I'm desperate gauge cluster help

Postby basketcase0302 » Wed Nov 08, 2017 6:46 am

"Doorjam13"]I have zero volts at the Blue w/red wire but 11.4 ish from the other wires at the head light switch.


If you are measuring zero volts on the blue with red stripe wire (measuring at the wire end on the instrument panel harness-with the harness unplugged from the panel) your headlight switch is bad as earlier suggested.
The rheostat that supplies power to that wire, (from the headlight switch) gets it's power off of a spring (you'll see it when you pull out the headlight switch-it lies behind the round white ceramic piece in the below link photo) and a bimetallic strip that has a contact point on it that wears out frequently.
The good thing is the headlight switch is a cheap enough and readily available part (real easy to find) but order a good one or you'll be very disappointed as some of the quality of the new ones are as bad as the old FoMoCo part you'd be pulling out.

DC has it and I'd def pay the extra $10-you'll be so...glad you did with this part:
http://dennis-carpenter.com/headlight-s ... Z-11654-A/
Jeff
viewtopic.php?f=22&t=46251
SOLD-71 F-350 dually flatbed, 302 / .030 over V-8 with a "baby"C-6, B & M truckshifter, Dana70/4.11 ratio, intermittent wipers, tilt steering, full LED lighting on the flat bed, and no stereo yet (this way I can hear the rattles to diagnose)! SOLD!
A lot of "oddball" Ford parts collected from working on them for 34 years now!
2008 Ford Escape 4 x 4

I'm "on the fence" about another bump right now / still looking at them / but not real sure if I'm ready for it or not (until I get moved). :(

Doorjam13
New Member
New Member
Posts: 20
Joined: Thu Mar 16, 2017 10:36 pm

Re: I'm desperate gauge cluster help

Postby Doorjam13 » Fri Nov 10, 2017 6:12 pm

So I put in the new headlight switch and I now have lights in the dash :hd:

My fuel and ALT gauge is still not functioning. I have an auxiliary water temp and oil pressure gauge I'm not sure if the original ones are working.

User avatar
basketcase0302
100% FORDified!
100% FORDified!
Posts: 5814
Joined: Thu Jan 26, 2006 7:11 am
Location: Tennessee, Chattanooga (Choo-Choo town)

Re: I'm desperate gauge cluster help

Postby basketcase0302 » Fri Nov 10, 2017 7:31 pm

"Doorjam13"]So I put in the new headlight switch and I now have lights in the dash :hd:
My fuel and ALT gauge is still not functioning. I have an auxiliary water temp and oil pressure gauge I'm not sure if the original ones are working.


These are all separate issues that have to be dealt with one at a time. Good deal on the dash / instrument panel lights as the printed circuit board is a pricey item if that were the culprit.

The fuel gauge would be the next thing I'd tackle. Take the volt meter, (test light will be of no use whatsoever for this also) and test for power at the fuel sending unit supply voltage wire behind the seat on the tank sending unit. The gas tank sending unit, (behind the seat in the top of the tank) will likely be the fault there as the gauge itself rarely fails. :thup:
Jeff
viewtopic.php?f=22&t=46251
SOLD-71 F-350 dually flatbed, 302 / .030 over V-8 with a "baby"C-6, B & M truckshifter, Dana70/4.11 ratio, intermittent wipers, tilt steering, full LED lighting on the flat bed, and no stereo yet (this way I can hear the rattles to diagnose)! SOLD!
A lot of "oddball" Ford parts collected from working on them for 34 years now!
2008 Ford Escape 4 x 4

I'm "on the fence" about another bump right now / still looking at them / but not real sure if I'm ready for it or not (until I get moved). :(


Return to “Interior”

Who is online

Users browsing this forum: No registered users